import Foundation
let pattern = #"(?<number1>\d{8})_(?<number2>\d{4})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
c:\Folder\Nr_11111111_2222.pdf
c:\Folder\Nr_11111111_2222_1.pdf
c:\Folder\Nr_33333333_2222.pdf
c:\Folder\Nr_33333333_2222.pdf
c:\Folder\Nr_44444444_2222.pdf
c:\Folder\Nr_44444444_2222.pdf
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)