import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<number1>\\d{8})_(?<number2>\\d{4})";
final String string = "c:\\Folder\\Nr_11111111_2222.pdf\n"
+ "c:\\Folder\\Nr_11111111_2222_1.pdf\n"
+ "c:\\Folder\\Nr_33333333_2222.pdf\n"
+ "c:\\Folder\\Nr_33333333_2222.pdf\n"
+ "c:\\Folder\\Nr_44444444_2222.pdf\n"
+ "c:\\Folder\\Nr_44444444_2222.pdf";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}