const regex = /(.*?)(srn\.firsttname)( like '%?\w+%?' and )(.*?)(srn\.lastname)(.*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*?)(srn\\.firsttname)( like \'%?\\w+%?\' and )(.*?)(srn\\.lastname)(.*)', 'g')
const str = `Results where srn.firsttname like 'Chicken%' and coalesce(sri.DocumentType_id,0) not in (71, 72, 70, 69) and having srn.lastname like 'Alfredo%'`;
const subst = `$1$5$3$2$6`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);