import Foundation
let pattern = #"(.*?)(srn\.firsttname)( like '%?\w+%?' and )(.*?)(srn\.lastname)(.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Results where srn.firsttname like 'Chicken%' and coalesce(sri.DocumentType_id,0) not in (71, 72, 70, 69) and having srn.lastname like 'Alfredo%'"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$5$3$2$6"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)