$re = '/(.*?)(srn\.firsttname)( like \'%?\w+%?\' and )(.*?)(srn\.lastname)(.*)/';
$str = 'Results where srn.firsttname like \'Chicken%\' and coalesce(sri.DocumentType_id,0) not in (71, 72, 70, 69) and having srn.lastname like \'Alfredo%\'';
$subst = "$1$5$3$2$6";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;