#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\S+),?\s.[^@]*(@\r?\n\1.*|\r?\n\1.*@)$"
Local $sString = "увацуа каакак акака акакуа" & @CRLF & _
"æввонгхуар дармоед, тунеядец." & @CRLF & _
"æввонгхуар дармоед, тунеядец" & @CRLF & _
"æваст т.ж. æвваст 1) вдруг, внезапно, быстро, нæр неожиданно раздавшийся крик;" & @CRLF & _
"æваст тж. æвваст енно æваст гъæр − неожиданно раздавшмовольно, без ведома@" & @CRLF & _
"æвастæй самовольно, без спроса; произ¬вольно." & @CRLF & _
"æвастæй самовольно, без спроса; произвольно@" & @CRLF & _
"æвастгъæр гром, междометие.æввонгхуар дармоед, тунеядец." & @CRLF & _
"æввонгхуар дармоед, тунеядец"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")