import Foundation
let pattern = #"^(\S+),?\s.[^@]*(@\r?\n\1.*|\r?\n\1.*@)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
увацуа каакак акака акакуа
æввонгхуар дармоед, тунеядец.
æввонгхуар дармоед, тунеядец
æваст т.ж. æвваст 1) вдруг, внезапно, быстро, нæр неожиданно раздавшийся крик;
æваст тж. æвваст енно æваст гъæр − неожиданно раздавшмовольно, без ведома@
æвастæй самовольно, без спроса; произ¬вольно.
æвастæй самовольно, без спроса; произвольно@
æвастгъæр гром, междометие.æввонгхуар дармоед, тунеядец.
æввонгхуар дармоед, тунеядец
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)