use strict;
my $str = 'увацуа каакак акака акакуа
æввонгхуар дармоед, тунеядец.
æввонгхуар дармоед, тунеядец
æваст т.ж. æвваст 1) вдруг, внезапно, быстро, нæр неожиданно раздавшийся крик;
æваст тж. æвваст енно æваст гъæр − неожиданно раздавшмовольно, без ведома@
æвастæй самовольно, без спроса; произ¬вольно.
æвастæй самовольно, без спроса; произвольно@
æвастгъæр гром, междометие.æввонгхуар дармоед, тунеядец.
æввонгхуар дармоед, тунеядец';
my $regex = qr/^(\S+),?\s.[^@]*(@\r?\n\1.*|\r?\n\1.*@)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}