import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\S+),?\\s.[^@]*(@\\r?\\n\\1.*|\\r?\\n\\1.*@)$";
final String string = "увацуа каакак акака акакуа\n"
+ "æввонгхуар дармоед, тунеядец.\n"
+ "æввонгхуар дармоед, тунеядец\n"
+ "æваст т.ж. æвваст 1) вдруг, внезапно, быстро, нæр неожиданно раздавшийся крик;\n"
+ "æваст тж. æвваст енно æваст гъæр − неожиданно раздавшмовольно, без ведома@\n"
+ "æвастæй самовольно, без спроса; произ¬вольно.\n"
+ "æвастæй самовольно, без спроса; произвольно@\n"
+ "æвастгъæр гром, междометие.æввонгхуар дармоед, тунеядец.\n"
+ "æввонгхуар дармоед, тунеядец";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}