#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=[\w\s-+.])\s*[-+.'\w]+@[-.\w]+\.[-.\w]+\s*$"
Local $sString = "dfdfd@bcvb.com," & @CRLF & _
"dfdfd@bcvb.com`" & @CRLF & _
"test@test.com" & @CRLF & _
"'d@dfgdfg.com" & @CRLF & _
"`d@dfgdfg.com" & @CRLF & _
"ab12@bc.co" & @CRLF & _
" space@test.check "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")