re = /^(?=[\w\s-+.])\s*[-+.'\w]+@[-.\w]+\.[-.\w]+\s*$/m
str = 'dfdfd@bcvb.com,
dfdfd@bcvb.com`
test@test.com
\'d@dfgdfg.com
`d@dfgdfg.com
ab12@bc.co
space@test.check '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end