$re = '/^(?=[\w\s-+.])\s*[-+.\'\w]+@[-.\w]+\.[-.\w]+\s*$/m';
$str = 'dfdfd@bcvb.com,
dfdfd@bcvb.com`
test@test.com
\'d@dfgdfg.com
`d@dfgdfg.com
ab12@bc.co
space@test.check ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);