import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=[\\w\\s-+.])\\s*[-+.'\\w]+@[-.\\w]+\\.[-.\\w]+\\s*$";
final String string = "dfdfd@bcvb.com,\n"
+ "dfdfd@bcvb.com`\n"
+ "test@test.com\n"
+ "'d@dfgdfg.com\n"
+ "`d@dfgdfg.com\n"
+ "ab12@bc.co\n"
+ " space@test.check ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}