using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d{3}(?!.*?-)[\s\S]*?Download[\s\S]*?(?=\d)";
string input = @"1
00:00:39,243 --> 00:00:45,820
This line is ok
2
00:00:46,243 --> 00:00:51,820
This line with
""Ads"" word should be deleted
and its next line
3
00:01:04,243 --> 00:01:05,820
This line with
""Download"" word should be deleted
and its next line
4
00:01:08,664 --> 00:01:12,331
An ok line
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}