import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{3}(?!.*?-)[\\s\\S]*?Download[\\s\\S]*?(?=\\d)";
final String string = "1\n"
+ "00:00:39,243 --> 00:00:45,820\n"
+ "This line is ok\n\n"
+ "2\n"
+ "00:00:46,243 --> 00:00:51,820\n"
+ "This line with\n"
+ "\"Ads\" word should be deleted\n"
+ "and its next line\n\n"
+ "3\n"
+ "00:01:04,243 --> 00:01:05,820\n"
+ "This line with\n"
+ "\"Download\" word should be deleted\n"
+ "and its next line\n\n"
+ "4\n"
+ "00:01:08,664 --> 00:01:12,331\n"
+ "An ok line\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}