# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\d{3}(?!.*?-)[\s\S]*?Download[\s\S]*?(?=\d)"
test_str = ("1\n"
"00:00:39,243 --> 00:00:45,820\n"
"This line is ok\n\n"
"2\n"
"00:00:46,243 --> 00:00:51,820\n"
"This line with\n"
"\"Ads\" word should be deleted\n"
"and its next line\n\n"
"3\n"
"00:01:04,243 --> 00:01:05,820\n"
"This line with\n"
"\"Download\" word should be deleted\n"
"and its next line\n\n"
"4\n"
"00:01:08,664 --> 00:01:12,331\n"
"An ok line\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.