use strict;
my $str = '1
00:00:39,243 --> 00:00:45,820
This line is ok
2
00:00:46,243 --> 00:00:51,820
This line with
"Ads" word should be deleted
and its next line
3
00:01:04,243 --> 00:01:05,820
This line with
"Download" word should be deleted
and its next line
4
00:01:08,664 --> 00:01:12,331
An ok line
';
my $regex = qr/\d{3}(?!.*?-)[\s\S]*?Download[\s\S]*?(?=\d)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}