re = /\d{3}(?!.*?-)[\s\S]*?Download[\s\S]*?(?=\d)/m
str = '1
00:00:39,243 --> 00:00:45,820
This line is ok
2
00:00:46,243 --> 00:00:51,820
This line with
"Ads" word should be deleted
and its next line
3
00:01:04,243 --> 00:01:05,820
This line with
"Download" word should be deleted
and its next line
4
00:01:08,664 --> 00:01:12,331
An ok line
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end