# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:^([1-9]{9}[ABCD]{1,4})(?=0{1,5}\d{1,5}D*$)|\G)0/$1 /gm;t' <<< "123456789ABCD00001DDD
123456789AAA00000123DD"