re = /(?:^([1-9]{9}[ABCD]{1,4})(?=0{1,5}\d{1,5}D*$)|\G)0/m
str = '123456789ABCD00001DDD
123456789AAA00000123DD'
subst = '$1 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result