use strict;
my $str = '123456789ABCD00001DDD
123456789AAA00000123DD';
my $regex = qr/(?:^([1-9]{9}[ABCD]{1,4})(?=0{1,5}\d{1,5}D*$)|\G)0/mp;
my $subst = '$1 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";