import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^([1-9]{9}[ABCD]{1,4})(?=0{1,5}\\d{1,5}D*$)|\\G)0";
final String string = "123456789ABCD00001DDD\n"
+ "123456789AAA00000123DD";
final String subst = "$1 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}