const regex = /(?:^([1-9]{9}[ABCD]{1,4})(?=0{1,5}\d{1,5}D*$)|\G)0/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^([1-9]{9}[ABCD]{1,4})(?=0{1,5}\\d{1,5}D*$)|\\G)0', 'gm')
const str = `123456789ABCD00001DDD
123456789AAA00000123DD`;
const subst = `$1 `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);