#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?!\d+(?:[eE]\d+)?\b)[a-zA-Z0-9]+"
Local $sString = "(A+B1)**2.5" & @CRLF & _
"" & @CRLF & _
"123243" & @CRLF & _
"345 35 43543 543 5 53 w sdfdfsdf" & @CRLF & _
"1e3 4.5e1" & @CRLF & _
"1a" & @CRLF & _
"1E3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")