using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?!\d+(?:[eE]\d+)?\b)[a-zA-Z0-9]+";
string input = @"(A+B1)**2.5
123243
345 35 43543 543 5 53 w sdfdfsdf
1e3 4.5e1
1a
1E3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}