const regex = new RegExp('\\b(?!\\d+(?:[eE]\\d+)?\\b)[a-zA-Z0-9]+', 'gm')
const str = `(A+B1)**2.5
123243
345 35 43543 543 5 53 w sdfdfsdf
1e3 4.5e1
1a
1E3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}