import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?!\\d+(?:[eE]\\d+)?\\b)[a-zA-Z0-9]+";
final String string = "(A+B1)**2.5\n\n"
+ "123243\n"
+ "345 35 43543 543 5 53 w sdfdfsdf\n"
+ "1e3 4.5e1\n"
+ "1a\n"
+ "1E3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}