re = /\b(?!\d+(?:[eE]\d+)?\b)[a-zA-Z0-9]+/m
str = '(A+B1)**2.5
123243
345 35 43543 543 5 53 w sdfdfsdf
1e3 4.5e1
1a
1E3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end