package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?P<key>[A-Z]+)=(")?(?P<value>(?(2)[^"]*|\S+))`)
var str = `update DIFFICULTY=1 DESCRIPTION="some long run on description"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}