re = /\b(?P<key>[A-Z]+)=(")?(?P<value>(?(2)[^"]*|\S+))/m
str = 'update DIFFICULTY=1 DESCRIPTION="some long run on description"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end