// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\b(?P<key>[A-Z]+)=(")?(?P<value>(?(2)[^"]*|\S+))"#).unwrap();
let string = "update DIFFICULTY=1 DESCRIPTION=\"some long run on description\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}