$re = '~\b(?P<key>[A-Z]+)=(")?(?P<value>(?(2)[^"]*|\S+))~m';
$str = 'update DIFFICULTY=1 DESCRIPTION="some long run on description"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);