import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?:Mike: )((?!.*_keyword).*))[\\s\\S]*(?:(?:Sonya: )((?!.*_keyword).*))";
final String string = "..some_text_and_linebreaks..\n"
+ " Mike: Using some_1eyword\n"
+ "..some_text_and_linebreaks..\n"
+ " Sonya: Using another_1eyword\n"
+ "..some_text_and_linebreaks..";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}