use strict;
my $str = '..some_text_and_linebreaks..
Mike: Using some_1eyword
..some_text_and_linebreaks..
Sonya: Using another_1eyword
..some_text_and_linebreaks..';
my $regex = qr/(?:(?:Mike: )((?!.*_keyword).*))[\s\S]*(?:(?:Sonya: )((?!.*_keyword).*))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}