re = /(?:(?:Mike: )((?!.*_keyword).*))[\s\S]*(?:(?:Sonya: )((?!.*_keyword).*))/
str = '..some_text_and_linebreaks..
Mike: Using some_1eyword
..some_text_and_linebreaks..
Sonya: Using another_1eyword
..some_text_and_linebreaks..'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end