const regex = /(?:(?:Mike: )((?!.*_keyword).*))[\s\S]*(?:(?:Sonya: )((?!.*_keyword).*))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?:Mike: )((?!.*_keyword).*))[\\s\\S]*(?:(?:Sonya: )((?!.*_keyword).*))', 'g')
const str = `..some_text_and_linebreaks..
Mike: Using some_1eyword
..some_text_and_linebreaks..
Sonya: Using another_1eyword
..some_text_and_linebreaks..`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}