use strict;
my $str = 'sada yourtext \'yourtext \' "yourtext uud" yourtext';
my $regex = qr/yourtext(?=(?:[^'\"]*(?:'|\")[^'\"]*(?:'|\"))*[^'\"]*$)/mp;
my $subst = '-------';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";