import Foundation
let pattern = #"yourtext(?=(?:[^'\"]*(?:'|\")[^'\"]*(?:'|\"))*[^'\"]*$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"sada yourtext 'yourtext ' "yourtext uud" yourtext"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"-------"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)