$re = '/yourtext(?=(?:[^\'\"]*(?:\'|\")[^\'\"]*(?:\'|\"))*[^\'\"]*$)/m';
$str = 'sada yourtext \'yourtext \' "yourtext uud" yourtext';
$subst = "-------";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;