re = /yourtext(?=(?:[^'\"]*(?:'|\")[^'\"]*(?:'|\"))*[^'\"]*$)/m
str = 'sada yourtext \'yourtext \' "yourtext uud" yourtext'
subst = '-------'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result