#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mu)[\p{L}0-9_.-]+@[0-9\p{L}.-]+\.[a-z.]{2,6}\b"
Local $sString = "Please email us at: some@example.com. You can also mail us at some@example.co.uk. Etc... hello@åä-ö.com" & @CRLF & _
"example@so.il.uk"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")