re = /[\p{L}0-9_.-]+@[0-9\p{L}.-]+\.[a-z.]{2,6}\b/m
str = 'Please email us at: some@example.com. You can also mail us at some@example.co.uk. Etc... hello@åä-ö.com
example@so.il.uk'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end