const regex = /[\p{L}0-9_.-]+@[0-9\p{L}.-]+\.[a-z.]{2,6}\b/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\p{L}0-9_.-]+@[0-9\\p{L}.-]+\\.[a-z.]{2,6}\\b', 'gmu')
const str = `Please email us at: some@example.com. You can also mail us at some@example.co.uk. Etc... hello@åä-ö.com
example@so.il.uk`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}