import re
regex = re.compile(r"[\p{L}0-9_.-]+@[0-9\p{L}.-]+\.[a-z.]{2,6}\b", flags=re.MULTILINE | re.UNICODE)
test_str = ("Please email us at: some@example.com. You can also mail us at some@example.co.uk. Etc... hello@åä-ö.com\n"
"example@so.il.uk")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")