using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<TM>\d+)\( (?P<starting>\d+)- (?P<ending>\d+)";
string input = @" 1( 16- 41), 2( 51- 73), 3( 86- 108) ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}