$re = '/(?P<TM>\d+)\( (?P<starting>\d+)- (?P<ending>\d+)/m';
$str = ' 1( 16- 41), 2( 51- 73), 3( 86- 108) ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);