package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?P<TM>\d+)\( (?P<starting>\d+)- (?P<ending>\d+)`)
var str = ` 1( 16- 41), 2( 51- 73), 3( 86- 108) `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}