re = /(?P<TM>\d+)\( (?P<starting>\d+)- (?P<ending>\d+)/m
str = ' 1( 16- 41), 2( 51- 73), 3( 86- 108) '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end