// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?P<TM>\d+)\( (?P<starting>\d+)- (?P<ending>\d+)").unwrap();
let string = " 1( 16- 41), 2( 51- 73), 3( 86- 108) ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}