#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)www\.[0-9]*\.xyz$"
Local $sString = "xyz.domain.com" & @CRLF & _
"www.domainwithxyz.com" & @CRLF & _
"www.xyz.com" & @CRLF & _
"www.somedomain.xyz" & @CRLF & _
"www.0123456.xyz" & @CRLF & _
"www.156489.xyz" & @CRLF & _
"www.321a5487.xyz"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")